// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"class="(.*?)""#).unwrap();
let string = "bla<p class=\"c1 c2\">blabla<button></button><div id=\"bla\" class=\"c1 c3\"></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}