re = /class="(.*?)"/
str = 'bla<p class="c1 c2">blabla<button></button><div id="bla" class="c1 c3"></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end