using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\*|[[:digit:]]{1,9})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:alpha:]]{3})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]];[[:blank:]]([[:print:]]*)$";
string input = @"PS : This is some examples :
* * * * * * * ; command
0 00 00 Mon 00 00 00 ; command
123456789 00 00 Mon 00 00 00 ; command
01234556789 00 00 Mon 00 00 00 ; command
0 00 00 0 00 00 00 ; command
0 0 0 Mon 0 0 0 ; command";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}