// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\*|[[:digit:]]{1,9})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:alpha:]]{3})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]];[[:blank:]]([[:print:]]*)$").unwrap();
let string = "PS : This is some examples :
* * * * * * * ; command
0 00 00 Mon 00 00 00 ; command
123456789 00 00 Mon 00 00 00 ; command
01234556789 00 00 Mon 00 00 00 ; command
0 00 00 0 00 00 00 ; command
0 0 0 Mon 0 0 0 ; command";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}