import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\*|[[:digit:]]{1,9})[[:blank:]](\\*|[[:digit:]]{2})[[:blank:]](\\*|[[:digit:]]{2})[[:blank:]](\\*|[[:alpha:]]{3})[[:blank:]](\\*|[[:digit:]]{2})[[:blank:]](\\*|[[:digit:]]{2})[[:blank:]](\\*|[[:digit:]]{2})[[:blank:]];[[:blank:]]([[:print:]]*)$";
final String string = "PS : This is some examples :\n\n"
+ "* * * * * * * ; command\n"
+ "0 00 00 Mon 00 00 00 ; command\n"
+ "123456789 00 00 Mon 00 00 00 ; command\n\n"
+ "01234556789 00 00 Mon 00 00 00 ; command\n"
+ "0 00 00 0 00 00 00 ; command\n"
+ "0 0 0 Mon 0 0 0 ; command";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}