using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">([^<]+)<(?:br|p)>";
string input = @"<r> this is text which I do not want <a> This is what I want!<br>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}