$re = '/>([^<]+)<(?:br|p)>/';
$str = '<r> this is text which I do not want <a> This is what I want!<br>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);