const regex = /\[url[^]]*\]((?:(?!\[\/url\]).)*youtu(?:(?!\[\/url\]).)*)\[\/url\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[url[^]]*\\]((?:(?!\\[\\\/url\\]).)*youtu(?:(?!\\[\\\/url\\]).)*)\\[\\\/url\\]', 'gm')
const str = `[url]blahyoutubeblah[/url] heyya [url]blahblah[/url] [url]www.youtube.com/blah[/url]
[url]foobar youtube[b]BOLD TEXT[/b][/url]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}