re = /\[url[^]]*\]((?:(?!\[\/url\]).)*youtu(?:(?!\[\/url\]).)*)\[\/url\]/m
str = '[url]blahyoutubeblah[/url] heyya [url]blahblah[/url] [url]www.youtube.com/blah[/url]
[url]foobar youtube[b]BOLD TEXT[/b][/url]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end