import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "File=[^=]+/(\\w+=[^/]+)/([^_]+)[^:\\s]*file\\.xml(\\.[^:\\s]*):([^,\\s]*)";
final String string = "Node=LTE03:File=/PMloc/dir22/XML/Network=ARX_ROOT_AO,Network=LTE,Network=Base,Manage=LTE,Element=LTE03/A20210115.1545+0530-1600+0530_Network=ARX_ROOT_AO,Network=LTE,Network=Base,Manage=LTE,Element=LTE03_file.xml.gz:Unit=U-3,Meter=1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}