use strict;
my $str = 'Node=LTE03:File=/PMloc/dir22/XML/Network=ARX_ROOT_AO,Network=LTE,Network=Base,Manage=LTE,Element=LTE03/A20210115.1545+0530-1600+0530_Network=ARX_ROOT_AO,Network=LTE,Network=Base,Manage=LTE,Element=LTE03_file.xml.gz:Unit=U-3,Meter=1
';
my $regex = qr`File=[^=]+/(\w+=[^/]+)/([^_]+)[^:\s]*file\.xml(\.[^:\s]*):([^,\s]*)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}