re = /File=[^=]+\/(\w+=[^\/]+)\/([^_]+)[^:\s]*file\.xml(\.[^:\s]*):([^,\s]*)/m
str = 'Node=LTE03:File=/PMloc/dir22/XML/Network=ARX_ROOT_AO,Network=LTE,Network=Base,Manage=LTE,Element=LTE03/A20210115.1545+0530-1600+0530_Network=ARX_ROOT_AO,Network=LTE,Network=Base,Manage=LTE,Element=LTE03_file.xml.gz:Unit=U-3,Meter=1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end