import re
regex = re.compile(r"(?<!\S)\d+(?:/\d+)+(?!\S)(*SKIP)(*F)|[/\\_\s]+", flags=re.MULTILINE)
test_str = "925/123 Black/Jack"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)