# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[rn](?=[A-Z0-9 ])/ /gm;t' <<< "r n r n r nFamily Medical History new r n r n r r r Roger nRobert n nDawson n49 nyears old , right shoulder"