use strict;
my $str = 'r n r n r nFamily Medical History new r n r n r r r Roger nRobert n nDawson n49 nyears old , right shoulder';
my $regex = qr/\b[rn](?=[A-Z0-9 ])/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";