re = /\b[rn](?=[A-Z0-9 ])/m
str = 'r n r n r nFamily Medical History new r n r n r r r Roger nRobert n nDawson n49 nyears old , right shoulder'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result