using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<(tr)(?: .*?)?\>(?:[^\<]|\<(.*?)\>[^\<]*\<\/\2\>)*\<\/\1\>";
string input = @"<body>
<tr attr=""hue"">
<p>hu3</p>
</tr>
</body>
<head>
<tr attr=""hue"">
<p>hu3</p>
</tr>
</head>
<foot>
<tr attr=""hue"">
hu3
</tr>
</foot>
<table>
<thead>
<tr data-remove=""true"">
<tr></tr>
<th>{{theadContent}}</th>
</tr>
</thead>
<tbody>
<tr data-remove=""true"">
<t>{{tbodyContent}}</t>
</tr>
</tbody>
<tfoot>
<tr data-remove=""true"">
<h>{{tfootContent}}</h>
</tr>
</tfoot>
</table>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}