$re = '/\<(tr)(?: .*?)?\>(?:[^\<]|\<(.*?)\>[^\<]*\<\/\2\>)*\<\/\1\>/s';
$str = '<body>
<tr attr="hue">
<p>hu3</p>
</tr>
</body>
<head>
<tr attr="hue">
<p>hu3</p>
</tr>
</head>
<foot>
<tr attr="hue">
hu3
</tr>
</foot>
<table>
<thead>
<tr data-remove="true">
<tr></tr>
<th>{{theadContent}}</th>
</tr>
</thead>
<tbody>
<tr data-remove="true">
<t>{{tbodyContent}}</t>
</tr>
</tbody>
<tfoot>
<tr data-remove="true">
<h>{{tfootContent}}</h>
</tr>
</tfoot>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);