use strict;
my $str = '<body>
<tr attr="hue">
<p>hu3</p>
</tr>
</body>
<head>
<tr attr="hue">
<p>hu3</p>
</tr>
</head>
<foot>
<tr attr="hue">
hu3
</tr>
</foot>
<table>
<thead>
<tr data-remove="true">
<tr></tr>
<th>{{theadContent}}</th>
</tr>
</thead>
<tbody>
<tr data-remove="true">
<t>{{tbodyContent}}</t>
</tr>
</tbody>
<tfoot>
<tr data-remove="true">
<h>{{tfootContent}}</h>
</tr>
</tfoot>
</table>';
my $regex = qr/\<(tr)(?: .*?)?\>(?:[^\<]|\<(.*?)\>[^\<]*\<\/\2\>)*\<\/\1\>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}