using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(stxt|city):([^,\n]+)";
string input = @"stxt:usa,city:14
stxt:usa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}