package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(stxt|city):([^,\n]+)`)
var str = `stxt:usa,city:14
stxt:usa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}