#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[^a-zA-Z0-9_-]|^)([A-Za-z]{2,10}-\d{1,6})(?=[^a-zA-Z0-9_-]|$)"
Local $sString = "Merge pull request #2 in PAY/email-api from APP-8755-error to master" & @CRLF & _
"APP-8755 - fixup error handling" & @CRLF & _
"[RN] APP-8827 - Hooks up to email service" & @CRLF & _
"Merge pull request #157 in EUE-API/eue-api-dwp-service from EE-31627 to master" & @CRLF & _
"[EE-32070] Same logging work for TraceAllocate" & @CRLF & _
"Merge branch 'tag/candidate-develop-umbrella-2.17.2-20200429160812' into release" & @CRLF & _
"Merge pull request #177 in EUE-CW1/ipt-sp-appmsg-hops-listener from ORCH-642 to develop" & @CRLF & _
"ORCH-642 extended unit tests" & @CRLF & _
"ORCH-643 hello" & @CRLF & _
"[NG] testing FBISC-4612 does it correctly regex FBISC-542." & @CRLF & _
"[NG] testing FBISC-4612 does it correctly regex FBISC-542655" & @CRLF & _
"Revert APP-7491: Feign Retry with exception Mapping" & @CRLF & _
"Revert APP-7449" & @CRLF & _
""[NG] testing FBISC-4612 does it correctly regex FBISC-542.""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)