$re = '/(?<=[^a-zA-Z0-9_-]|^)([A-Za-z]{2,10}-\d{1,6})(?=[^a-zA-Z0-9_-]|$)/m';
$str = 'Merge pull request #2 in PAY/email-api from APP-8755-error to master
APP-8755 - fixup error handling
[RN] APP-8827 - Hooks up to email service
Merge pull request #157 in EUE-API/eue-api-dwp-service from EE-31627 to master
[EE-32070] Same logging work for TraceAllocate
Merge branch \'tag/candidate-develop-umbrella-2.17.2-20200429160812\' into release
Merge pull request #177 in EUE-CW1/ipt-sp-appmsg-hops-listener from ORCH-642 to develop
ORCH-642 extended unit tests
ORCH-643 hello
[NG] testing FBISC-4612 does it correctly regex FBISC-542.
[NG] testing FBISC-4612 does it correctly regex FBISC-542655
Revert APP-7491: Feign Retry with exception Mapping
Revert APP-7449
"[NG] testing FBISC-4612 does it correctly regex FBISC-542."';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;