import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^a-zA-Z0-9_-]|^)([A-Za-z]{2,10}-\\d{1,6})(?=[^a-zA-Z0-9_-]|$)";
final String string = "Merge pull request #2 in PAY/email-api from APP-8755-error to master\n"
+ "APP-8755 - fixup error handling\n"
+ "[RN] APP-8827 - Hooks up to email service\n"
+ "Merge pull request #157 in EUE-API/eue-api-dwp-service from EE-31627 to master\n"
+ "[EE-32070] Same logging work for TraceAllocate\n"
+ "Merge branch 'tag/candidate-develop-umbrella-2.17.2-20200429160812' into release\n"
+ "Merge pull request #177 in EUE-CW1/ipt-sp-appmsg-hops-listener from ORCH-642 to develop\n"
+ "ORCH-642 extended unit tests\n"
+ "ORCH-643 hello\n"
+ "[NG] testing FBISC-4612 does it correctly regex FBISC-542.\n"
+ "[NG] testing FBISC-4612 does it correctly regex FBISC-542655\n"
+ "Revert APP-7491: Feign Retry with exception Mapping\n"
+ "Revert APP-7449\n"
+ "\"[NG] testing FBISC-4612 does it correctly regex FBISC-542.\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}