#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[A-Z]\.(?=\s+[a-z]+\s*(?:[A-Z]\.\s+[a-z]+\s*)*([A-Z]+)\s*$)"
Local $sString = "P. salinarum" & @CRLF & _
"P. montana" & @CRLF & _
"P. conspicua" & @CRLF & _
"PLATESSA" & @CRLF & _
"A. cocconeiformis" & @CRLF & _
"A. coarctata" & @CRLF & _
"A. brevipes" & @CRLF & _
"ACHNANTHES"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)