re = /^[A-Z]\.(?=\s+[a-z]+\s*(?:[A-Z]\.\s+[a-z]+\s*)*([A-Z]+)\s*$)/m
str = 'P. salinarum
P. montana
P. conspicua
PLATESSA
A. cocconeiformis
A. coarctata
A. brevipes
ACHNANTHES'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result