use strict;
my $str = 'P. salinarum
P. montana
P. conspicua
PLATESSA
A. cocconeiformis
A. coarctata
A. brevipes
ACHNANTHES';
my $regex = qr/^[A-Z]\.(?=\s+[a-z]+\s*(?:[A-Z]\.\s+[a-z]+\s*)*([A-Z]+)\s*$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";