import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z-]+|[\\w]+)\\.(((?!\\.s1).+\\.)?(co1|az1|ut1|eng|au1)\\.(qprod|qops)\\.net)$";
final String string = "test-app.az1.qprod.net\n"
+ "jwm12535.s1.az1.qprod.net\n"
+ "testing2.eng.qops.net\n"
+ "kvm1.c1.co1.qprod.net\n"
+ "bs1.co1.qprod.net\n"
+ "staging.s1.co1.qprod.net\n"
+ "staging.co1.qprod.net\n"
+ "server.s1.co1.qprod.net\n"
+ "s1.co1.qprod.net\n"
+ "server2.co1.qprod.net\n"
+ "s.co1.qprod.net\n"
+ "testing.az1.qprod.net\n"
+ "something1.eng.qops.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}