re = /^([a-z-]+|[\w]+)\.(((?!\.s1).+\.)?(co1|az1|ut1|eng|au1)\.(qprod|qops)\.net)$/m
str = 'test-app.az1.qprod.net
jwm12535.s1.az1.qprod.net
testing2.eng.qops.net
kvm1.c1.co1.qprod.net
bs1.co1.qprod.net
staging.s1.co1.qprod.net
staging.co1.qprod.net
server.s1.co1.qprod.net
s1.co1.qprod.net
server2.co1.qprod.net
s.co1.qprod.net
testing.az1.qprod.net
something1.eng.qops.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end