# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/=(\S+(?:\s+=\S+)*)/$1/gm;t' <<< "KsKd2s4dAs =AhAd2s4dKs =AsAd2s4dKs 5s5d6s6d2c AsAd6s6d2c =AdQdKdJdTd =AhQhKhJhTh =AsQsKsJsTs"