package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)=(\S+(?:\s+=\S+)*)`)
var str = `KsKd2s4dAs =AhAd2s4dKs =AsAd2s4dKs 5s5d6s6d2c AsAd6s6d2c =AdQdKdJdTd =AhQhKhJhTh =AsQsKsJsTs`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}