re = /=(\S+(?:\s+=\S+)*)/m
str = 'KsKd2s4dAs =AhAd2s4dKs =AsAd2s4dKs 5s5d6s6d2c AsAd6s6d2c =AdQdKdJdTd =AhQhKhJhTh =AsQsKsJsTs'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result