#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^jamec\d*(?!\S)"
Local $sString = "jamec - match" & @CRLF & _
"jamec1234 - match" & @CRLF & _
"jamec12 - match" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"jamech - not match " & @CRLF & _
"jamech12 - not match" & @CRLF & _
"" & @CRLF & _
"jamec1234$" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")