using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^jamec\d*(?!\S)";
string input = @"jamec - match
jamec1234 - match
jamec12 - match
jamech - not match
jamech12 - not match
jamec1234$
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}