$re = '/^jamec\d*(?!\S)/m';
$str = 'jamec - match
jamec1234 - match
jamec12 - match
jamech - not match
jamech12 - not match
jamec1234$
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);