import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]{1,3})\\s*(\\d+(?:\\.\\d+)?)\\s*(\\.[A-Z]\\d*)\\s*([A-Z]\\d*)?\\s*(\\d\\d\\d\\d(?:-\\d\\d\\d\\d)?)?\\s*(.*)$";
final String string = "G2081.51 H8 1996";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}