re = /^([A-Z]{1,3})\s*(\d+(?:\.\d+)?)\s*(\.[A-Z]\d*)\s*([A-Z]\d*)?\s*(\d\d\d\d(?:-\d\d\d\d)?)?\s*(.*)$/
str = 'G2081.51 H8 1996'
# Print the match result
str.match(re) do |match|
puts match.to_s
end