#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-zA-Z])(.+)"
Local $sString = "11111111111" & @CRLF & _
"aaaaaaaa1" & @CRLF & _
"11111111a" & @CRLF & _
"1111111a^" & @CRLF & _
"1111111^" & @CRLF & _
"&^^!!!(" & @CRLF & _
"a$$$$^&aaa" & @CRLF & _
"@#%#$^23532dfgdfg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")