$re = '/^(?=.*[a-zA-Z])(.+)/m';
$str = '11111111111
aaaaaaaa1
11111111a
1111111a^
1111111^
&^^!!!(
a$$$$^&aaa
@#%#$^23532dfgdfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);