using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])(.+)";
string input = @"11111111111
aaaaaaaa1
11111111a
1111111a^
1111111^
&^^!!!(
a$$$$^&aaa
@#%#$^23532dfgdfg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}