#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w{2}-\w{2})/questions/(\d+)/.*$"
Local $sString = "en-us/questions/ask" & @CRLF & _
"en-us/questions/newest/15" & @CRLF & _
"en-us/questions/12/just-a-text-to-be-ignored" & @CRLF & _
"en-us/questions/newest"
Local $sSubst = "/questions.aspx?lang=\1&tab=\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)