const regex = new RegExp('^(\\w{2}-\\w{2})/questions/(\\d+)/.*$', 'gm')
const str = `en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored
en-us/questions/newest`;
const subst = `/questions.aspx?lang=\1&tab=\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);