$re = '/^(\w{2}-\w{2})/questions/(\d+)/.*$/m';
$str = 'en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored
en-us/questions/newest';
$subst = "/questions.aspx?lang=\1&tab=\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;