#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)robert ([^p]*(?:p(?!almer)[^p]*)*) palmer sent for the boat"
Local $sString = "Match" & @CRLF & _
"robert eric palmer sent for the boat" & @CRLF & _
"robert eric william palmer sent for the boat" & @CRLF & _
"" & @CRLF & _
"No match" & @CRLF & _
"robert eric palmer palmer sent for the boat" & @CRLF & _
"robert eric william palmer palmer sent for the boat" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")