import re
regex = re.compile(r"robert ([^p]*(?:p(?!almer)[^p]*)*) palmer sent for the boat", flags=re.MULTILINE)
test_str = ("Match\n"
"robert eric palmer sent for the boat\n"
"robert eric william palmer sent for the boat\n\n"
"No match\n"
"robert eric palmer palmer sent for the boat\n"
"robert eric william palmer palmer sent for the boat\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")