const regex = /robert ([^p]*(?:p(?!almer)[^p]*)*) palmer sent for the boat/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('robert ([^p]*(?:p(?!almer)[^p]*)*) palmer sent for the boat', 'gm')
const str = `Match
robert eric palmer sent for the boat
robert eric william palmer sent for the boat
No match
robert eric palmer palmer sent for the boat
robert eric william palmer palmer sent for the boat
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}