$re = '/(?<=Param\(\s*\1|)(\[\w*\])/mi';
$str = '[cmdletbinding()]
Param(
[STRING]$CustomerName,
[STRING]$ClusterName,
)
[STRING]$CustomerName,
[STRING]$ClusterName,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);