re = /(?<=Param\(\s*\1|)(\[\w*\])/mi
str = '[cmdletbinding()]
Param(
[STRING]$CustomerName,
[STRING]$ClusterName,
)
[STRING]$CustomerName,
[STRING]$ClusterName,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end