#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[.]+"
Local $sString = "x8.ext.indeed.com" & @CRLF & _
"yk1.ext.indeed.com" & @CRLF & _
"za.indeed.com" & @CRLF & _
"zera.ext.indeed.com" & @CRLF & _
".envoy.eastus2.qa.notjet.net" & @CRLF & _
".envoy.westus.qa.notjet.net" & @CRLF & _
".nomad.eastus2.qa.notjet.net" & @CRLF & _
".nomad.westus.qa.notjet.net" & @CRLF & _
".notjet.net" & @CRLF & _
".torbit.notjet.net" & @CRLF & _
"artifacts.notjet.net" & @CRLF & _
"bamf.notjet.net" & @CRLF & _
"bamfdb.notjet.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")