import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[.]+";
final String string = "x8.ext.indeed.com\n"
+ "yk1.ext.indeed.com\n"
+ "za.indeed.com\n"
+ "zera.ext.indeed.com\n"
+ ".envoy.eastus2.qa.notjet.net\n"
+ ".envoy.westus.qa.notjet.net\n"
+ ".nomad.eastus2.qa.notjet.net\n"
+ ".nomad.westus.qa.notjet.net\n"
+ ".notjet.net\n"
+ ".torbit.notjet.net\n"
+ "artifacts.notjet.net\n"
+ "bamf.notjet.net\n"
+ "bamfdb.notjet.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}